Browser requirements | Showcase Workshop

Browser requirements

Showcase Workshop has the following minimum browser requirements:

  • Internet Explorer 10+
  • Google Chrome (latest version)
  • Mozilla Firefox (latest version)
  • Safari (latest version)

*If your web browser is below the above requirements, a message will be displayed warning you about the potential of reduced functionality. For the best possible experience, please update your browser.